use strict;
my $str = 'Accept-Language: en-EN
n1.legend=0,1,meta,text,Legend,b1,30 chars max
n1.legend=0,1,meta,text,Legend,b1,30 chars maxb12test
r1.label=Contain
en-EN
0,1,meta,text,Legend,b1,30 chars max
0,1,meta,text,Legend,b1,30 chars maxb12test
Contain';
my $regex = qr/(?:^[^=:\r\n]+[=:]|\G(?!^))(?:b\d{1,2})?\K.*?(?=b\d{1,2}|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}