import re
regex = re.compile(r"(?:^[^=:\r\n]+[=:]|\G(?!^))(?:b\d{1,2})?\K.*?(?=b\d{1,2}|$)", flags=re.MULTILINE)
test_str = ("Accept-Language: en-EN\n"
"n1.legend=0,1,meta,text,Legend,b1,30 chars max\n"
"n1.legend=0,1,meta,text,Legend,b1,30 chars maxb12test\n"
"r1.label=Contain\n\n"
" en-EN\n"
"0,1,meta,text,Legend,b1,30 chars max\n"
"0,1,meta,text,Legend,b1,30 chars maxb12test\n"
"Contain")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")