#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)### remove the leading # from a line to uncomment it" & @CRLF & _
"#(r*)r # greedy, not possessive, 0 or more" & @CRLF & _
"(r+)r # greedy, not possessive, 1 or more" & @CRLF & _
"#(r*+)r # greedy, possessive, 1 or more"
Local $sString = "narwhal " & @CRLF & _
"narrative " & @CRLF & _
"narrrp " & @CRLF & _
"narrrrrrp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")