re = /### remove the leading # from a line to uncomment it
#(r*)r # greedy, not possessive, 0 or more
(r+)r # greedy, not possessive, 1 or more
#(r*+)r # greedy, possessive, 1 or more/x
str = 'narwhal
narrative
narrrp
narrrrrrp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end