import Foundation
let pattern = ####"""
### remove the leading # from a line to uncomment it
#(r*)r # greedy, not possessive, 0 or more
(r+)r # greedy, not possessive, 1 or more
#(r*+)r # greedy, possessive, 1 or more
"""####
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
narwhal
narrative
narrrp
narrrrrrp
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)