import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "### remove the leading # from a line to uncomment it\n"
+ "#(r*)r # greedy, not possessive, 0 or more\n"
+ "(r+)r # greedy, not possessive, 1 or more\n"
+ "#(r*+)r # greedy, possessive, 1 or more";
final String string = "narwhal \n"
+ "narrative \n"
+ "narrrp \n"
+ "narrrrrrp";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}