using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"### remove the leading # from a line to uncomment it
#(r*)r # greedy, not possessive, 0 or more
(r+)r # greedy, not possessive, 1 or more
#(r*+)r # greedy, possessive, 1 or more";
string input = @"narwhal
narrative
narrrp
narrrrrrp";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}