package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`### remove the leading # from a line to uncomment it
#(r*)r # greedy, not possessive, 0 or more
(r+)r # greedy, not possessive, 1 or more
#(r*+)r # greedy, possessive, 1 or more`)
var str = `narwhal
narrative
narrrp
narrrrrrp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}