// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)### remove the leading # from a line to uncomment it
#(r*)r # greedy, not possessive, 0 or more
(r+)r # greedy, not possessive, 1 or more
#(r*+)r # greedy, possessive, 1 or more").unwrap();
let string = "narwhal
narrative
narrrp
narrrrrrp";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}