#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\b\d?(?:[A-Z]\d)*[A-Z]?$"
Local $sString = "D1B2C4Q3" & @CRLF & _
"DDA1Q3" & @CRLF & _
"D$1A2B" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"11" & @CRLF & _
"A" & @CRLF & _
"AA" & @CRLF & _
"1A2B" & @CRLF & _
"1AA2" & @CRLF & _
"B2C33" & @CRLF & _
"B2C3D4" & @CRLF & _
"B2C3D4EE" & @CRLF & _
"B2C3D4E5G" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")