using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\b\d?(?:[A-Z]\d)*[A-Z]?$";
string input = @"D1B2C4Q3
DDA1Q3
D$1A2B
1
11
A
AA
1A2B
1AA2
B2C33
B2C3D4
B2C3D4EE
B2C3D4E5G
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}