re = /^\b\d?(?:[A-Z]\d)*[A-Z]?$/m
str = 'D1B2C4Q3
DDA1Q3
D$1A2B
1
11
A
AA
1A2B
1AA2
B2C33
B2C3D4
B2C3D4EE
B2C3D4E5G
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end