import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\b\\d?(?:[A-Z]\\d)*[A-Z]?$";
final String string = "D1B2C4Q3\n"
+ "DDA1Q3\n"
+ "D$1A2B\n\n"
+ "1\n"
+ "11\n"
+ "A\n"
+ "AA\n"
+ "1A2B\n"
+ "1AA2\n"
+ "B2C33\n"
+ "B2C3D4\n"
+ "B2C3D4EE\n"
+ "B2C3D4E5G\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}