// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\b\d?(?:[A-Z]\d)*[A-Z]?$").unwrap();
let string = "D1B2C4Q3
DDA1Q3
D$1A2B
1
11
A
AA
1A2B
1AA2
B2C33
B2C3D4
B2C3D4EE
B2C3D4E5G
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}