const regex = /^\b\d?(?:[A-Z]\d)*[A-Z]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\b\\d?(?:[A-Z]\\d)*[A-Z]?$', 'gm')
const str = `D1B2C4Q3
DDA1Q3
D\$1A2B
1
11
A
AA
1A2B
1AA2
B2C33
B2C3D4
B2C3D4EE
B2C3D4E5G
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}