#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^apple-touch-icon-(precomposed|[0-9]{2,4}x[0-9]{2,4})?\.png"
Local $sString = "apple-touch-icon-125x545.png" & @CRLF & _
"apple-touch-icon-1x545.png" & @CRLF & _
"apple-touch-icon-precomposed.png" & @CRLF & _
"apple-touch-couco.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")