// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^apple-touch-icon-(precomposed|[0-9]{2,4}x[0-9]{2,4})?\.png").unwrap();
let string = "apple-touch-icon-125x545.png
apple-touch-icon-1x545.png
apple-touch-icon-precomposed.png
apple-touch-couco.png";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}