package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^apple-touch-icon-(precomposed|[0-9]{2,4}x[0-9]{2,4})?\.png`)
var str = `apple-touch-icon-125x545.png
apple-touch-icon-1x545.png
apple-touch-icon-precomposed.png
apple-touch-couco.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}