$re = '/^apple-touch-icon-(precomposed|[0-9]{2,4}x[0-9]{2,4})?\.png/m';
$str = 'apple-touch-icon-125x545.png
apple-touch-icon-1x545.png
apple-touch-icon-precomposed.png
apple-touch-couco.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);