using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^apple-touch-icon-(precomposed|[0-9]{2,4}x[0-9]{2,4})?\.png";
string input = @"apple-touch-icon-125x545.png
apple-touch-icon-1x545.png
apple-touch-icon-precomposed.png
apple-touch-couco.png";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}