const regex = /^apple-touch-icon-(precomposed|[0-9]{2,4}x[0-9]{2,4})?\.png/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^apple-touch-icon-(precomposed|[0-9]{2,4}x[0-9]{2,4})?\\.png', 'gm')
const str = `apple-touch-icon-125x545.png
apple-touch-icon-1x545.png
apple-touch-icon-precomposed.png
apple-touch-couco.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}