import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^apple-touch-icon-(precomposed|[0-9]{2,4}x[0-9]{2,4})?\\.png";
final String string = "apple-touch-icon-125x545.png\n"
+ "apple-touch-icon-1x545.png\n"
+ "apple-touch-icon-precomposed.png\n"
+ "apple-touch-couco.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}