using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""sender"":.*?""id"":""(?<senderId>\d+)""";
string input = @"""{""object"":""page"",""entry"":[{""id"":""111111111111111"",""messaging"":[{""sender"":{""id"":""49783635606516156"", ""options"":""TETX_ARRAY""},""recipient"":{""id"":""111111111111111""},""message"":{""mid"":""m_secret"",""text"":""\/start""}}]}]}"";
""{""object"":""page"",""entry"":[{""id"":""111111111111111"",""messaging"":[{""sender"":{""options"":""TETX_ARRAY"", ""id"":""49783635606516156""},""recipient"":{""id"":""111111111111111""},""message"":{""mid"":""m_secret"",""text"":""\/start""}}]}]}"";";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}