const regex = /"sender":.*?"id":"(?<senderId>\d+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"sender":.*?"id":"(?<senderId>\\d+)"', 'gm')
const str = `"{"object":"page","entry":[{"id":"111111111111111","messaging":[{"sender":{"id":"49783635606516156", "options":"TETX_ARRAY"},"recipient":{"id":"111111111111111"},"message":{"mid":"m_secret","text":"\\/start"}}]}]}";
"{"object":"page","entry":[{"id":"111111111111111","messaging":[{"sender":{"options":"TETX_ARRAY", "id":"49783635606516156"},"recipient":{"id":"111111111111111"},"message":{"mid":"m_secret","text":"\\/start"}}]}]}";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}