import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"sender\":.*?\"id\":\"(?<senderId>\\d+)\"";
final String string = "\"{\"object\":\"page\",\"entry\":[{\"id\":\"111111111111111\",\"messaging\":[{\"sender\":{\"id\":\"49783635606516156\", \"options\":\"TETX_ARRAY\"},\"recipient\":{\"id\":\"111111111111111\"},\"message\":{\"mid\":\"m_secret\",\"text\":\"\\/start\"}}]}]}\";\n\n"
+ "\"{\"object\":\"page\",\"entry\":[{\"id\":\"111111111111111\",\"messaging\":[{\"sender\":{\"options\":\"TETX_ARRAY\", \"id\":\"49783635606516156\"},\"recipient\":{\"id\":\"111111111111111\"},\"message\":{\"mid\":\"m_secret\",\"text\":\"\\/start\"}}]}]}\";";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}