use strict;
my $str = '"{"object":"page","entry":[{"id":"111111111111111","messaging":[{"sender":{"id":"49783635606516156", "options":"TETX_ARRAY"},"recipient":{"id":"111111111111111"},"message":{"mid":"m_secret","text":"\\/start"}}]}]}";
"{"object":"page","entry":[{"id":"111111111111111","messaging":[{"sender":{"options":"TETX_ARRAY", "id":"49783635606516156"},"recipient":{"id":"111111111111111"},"message":{"mid":"m_secret","text":"\\/start"}}]}]}";';
my $regex = qr/"sender":.*?"id":"(?<senderId>\d+)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}