// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"sender":.*?"id":"(?<senderId>\d+)""#).unwrap();
let string = "\"{\"object\":\"page\",\"entry\":[{\"id\":\"111111111111111\",\"messaging\":[{\"sender\":{\"id\":\"49783635606516156\", \"options\":\"TETX_ARRAY\"},\"recipient\":{\"id\":\"111111111111111\"},\"message\":{\"mid\":\"m_secret\",\"text\":\"\\/start\"}}]}]}\";
\"{\"object\":\"page\",\"entry\":[{\"id\":\"111111111111111\",\"messaging\":[{\"sender\":{\"options\":\"TETX_ARRAY\", \"id\":\"49783635606516156\"},\"recipient\":{\"id\":\"111111111111111\"},\"message\":{\"mid\":\"m_secret\",\"text\":\"\\/start\"}}]}]}\";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}