$re = '/"sender":.*?"id":"(?<senderId>\d+)"/m';
$str = '"{"object":"page","entry":[{"id":"111111111111111","messaging":[{"sender":{"id":"49783635606516156", "options":"TETX_ARRAY"},"recipient":{"id":"111111111111111"},"message":{"mid":"m_secret","text":"\\/start"}}]}]}";
"{"object":"page","entry":[{"id":"111111111111111","messaging":[{"sender":{"options":"TETX_ARRAY", "id":"49783635606516156"},"recipient":{"id":"111111111111111"},"message":{"mid":"m_secret","text":"\\/start"}}]}]}";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);