using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<!\.)\d{3}(?:\.\d{2})?\b(?!\.)";
string input = @"X306
50.17080
8.69507,
50.178075,
50.050512
117.234
49.172
129
105.123432
107.23";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}