import Foundation
let pattern = #"\b(?<!\.)\d{3}(?:\.\d{2})?\b(?!\.)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
X306
50.17080
8.69507,
50.178075,
50.050512
117.234
49.172
129
105.123432
107.23
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)