use strict;
my $str = 'X306
50.17080
8.69507,
50.178075,
50.050512
117.234
49.172
129
105.123432
107.23';
my $regex = qr/\b(?<!\.)\d{3}(?:\.\d{2})?\b(?!\.)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}