import re
regex = re.compile(r"\b(?<!\.)\d{3}(?:\.\d{2})?\b(?!\.)")
test_str = ("X306\n"
"50.17080\n"
"8.69507,\n"
"50.178075,\n"
"50.050512\n"
"117.234\n"
"49.172\n"
"129\n"
"105.123432\n"
"107.23")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")