const regex = /\b(?<!\.)\d{3}(?:\.\d{2})?\b(?!\.)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<!\\.)\\d{3}(?:\\.\\d{2})?\\b(?!\\.)', 'g')
const str = `X306
50.17080
8.69507,
50.178075,
50.050512
117.234
49.172
129
105.123432
107.23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}