#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^https?:\/\/(?:www\.)?(.+)"
Local $sString = "http://domain.com" & @CRLF & _
"http://www.domain.com" & @CRLF & _
"https://domain.com" & @CRLF & _
"https://www.domain.com"
Local $sSubst = "https://www.${1}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)