$re = '/^https?:\/\/(?:www\.)?(.+)/m';
$str = 'http://domain.com
http://www.domain.com
https://domain.com
https://www.domain.com';
$subst = "https://www.${1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;