use strict;
my $str = 'http://domain.com
http://www.domain.com
https://domain.com
https://www.domain.com';
my $regex = qr/^https?:\/\/(?:www\.)?(.+)/mp;
my $subst = 'https://www.${1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";