const regex = /^https?:\/\/(?:www\.)?(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/(?:www\\.)?(.+)', 'gm')
const str = `http://domain.com
http://www.domain.com
https://domain.com
https://www.domain.com`;
const subst = `https://www.${1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);