re = /^https?:\/\/(?:www\.)?(.+)/m
str = 'http://domain.com
http://www.domain.com
https://domain.com
https://www.domain.com'
subst = 'https://www.${1}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result