import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/(?:www\\.)?(.+)";
final String string = "http://domain.com\n"
+ "http://www.domain.com\n"
+ "https://domain.com\n"
+ "https://www.domain.com";
final String subst = "https://www.${1}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}