#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<img.*src=\"[^?]*).*(\">$)"
Local $sString = "<img alt="" src="xxx.com/ooo.jpg?12345">"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)