const regex = /(<img.*src=\"[^?]*).*(\">$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<img.*src=\\"[^?]*).*(\\">$)', 'g')
const str = `<img alt="" src="xxx.com/ooo.jpg?12345">`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);