use strict;
my $str = '<img alt="" src="xxx.com/ooo.jpg?12345">';
my $regex = qr/(<img.*src=\"[^?]*).*(\">$)/p;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";