package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<img.*src=\"[^?]*).*(\">$)`)
var str = `<img alt="" src="xxx.com/ooo.jpg?12345">`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}