re = /(<img.*src=\"[^?]*).*(\">$)/
str = '<img alt="" src="xxx.com/ooo.jpg?12345">'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result