$re = '/(<img.*src=\"[^?]*).*(\">$)/';
$str = '<img alt="" src="xxx.com/ooo.jpg?12345">';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;