using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img.*src=\""[^?]*).*(\"">$)";
string substitution = @"\1\2";
string input = @"<img alt="" src=""xxx.com/ooo.jpg?12345"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}