#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(emplacement|implantation) (n\s?°|n|numero|\W)(\s?1\s?bis)"
Local $sString = "emplacement n1bis" & @CRLF & _
"emplacement n 1bis" & @CRLF & _
"" & @CRLF & _
"emplacement n°1bis " & @CRLF & _
"emplacement n° 1bis" & @CRLF & _
"" & @CRLF & _
"emplacement numero 1bis " & @CRLF & _
"emplacement numero 1 bis " & @CRLF & _
"" & @CRLF & _
"implantation : 1bis"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")