re = /(emplacement|implantation) (n\s?°|n|numero|\W)(\s?1\s?bis)/m
str = 'emplacement n1bis
emplacement n 1bis
emplacement n°1bis
emplacement n° 1bis
emplacement numero 1bis
emplacement numero 1 bis
implantation : 1bis'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end