const regex = /(emplacement|implantation) (n\s?°|n|numero|\W)(\s?1\s?bis)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(emplacement|implantation) (n\\s?°|n|numero|\\W)(\\s?1\\s?bis)', 'gm')
const str = `emplacement n1bis
emplacement n 1bis
emplacement n°1bis
emplacement n° 1bis
emplacement numero 1bis
emplacement numero 1 bis
implantation : 1bis`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}