// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(emplacement|implantation) (n\s?°|n|numero|\W)(\s?1\s?bis)").unwrap();
let string = "emplacement n1bis
emplacement n 1bis
emplacement n°1bis
emplacement n° 1bis
emplacement numero 1bis
emplacement numero 1 bis
implantation : 1bis";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}